Assassin's Creed Origins Stutter

Avatar image for Diddies
#1 Edited by Diddies (2320 posts) -

I saw that people were complaining about this game being CPU intensive. However, my game stutters like crazy. I am running the game at 3440x1440 and it stutters every few seconds. I have everything turned up to ultra. I would believe my 1080Ti and 6800k overclocked to 4.2 could handle. Is there something that I need to change or is this the way this game is? I have googled and seen lots of problems about this issue already.

Avatar image for Diddies
#2 Posted by Diddies (2320 posts) -

I even tried turning off Vsync and turning AA to adaptive and still issues.

Avatar image for BassMan
#3 Edited by BassMan (9494 posts) -

I don't have the game, but try setting max pre-rendered frames to 1 in Nvidia control panel. That sometimes fixes frame pacing issues.

Avatar image for Diddies
#4 Posted by Diddies (2320 posts) -

@BassMan: It still stutters. I do not know what the issue is. I am running, in combat, anything and there are slightly small stutters every 3-5 seconds. It is annoying and makes me not want to play.

Avatar image for BassMan
#5 Edited by BassMan (9494 posts) -

@Diddies: I wouldn't play it like that either. Try setting the power management to maximum performance (I always have it max) as it seems to help some...

http://steamcommunity.com/app/582160/discussions/0/1618346571422282974/

Avatar image for GTR12
#6 Posted by GTR12 (13294 posts) -

Turn the graphics down and try it?

Avatar image for couly
#7 Posted by couly (6244 posts) -

Your machine can't handle it, turn down the settings, it's as simple as that

Avatar image for Mickeyminime
#8 Posted by Mickeyminime (1432 posts) -

I've not noticed any problems with mine, although my processor is 8700K, the graphics card is the same though.

Avatar image for FelipeInside
#9 Posted by FelipeInside (28548 posts) -

@Diddies said:

I saw that people were complaining about this game being CPU intensive. However, my game stutters like crazy. I am running the game at 3440x1440 and it stutters every few seconds. I have everything turned up to ultra. I would believe my 1080Ti and 6800k overclocked to 4.2 could handle. Is there something that I need to change or is this the way this game is? I have googled and seen lots of problems about this issue already.

My one ran perfect all the way through but I was playing at 1080p and had a few settings down from Ultra.

Specs in my sig.

Avatar image for RyviusARC
#10 Posted by RyviusARC (5705 posts) -

I run my game at max settings at 3840x2160 resolution and get no stuttering.

I have an i7 4770k and a 1080ti with the game installed on an SSD.

Maybe you should try installing the game on an SSD.

Avatar image for Gatygun
#11 Posted by Gatygun (1323 posts) -

  • nVidia control panel settings - prefer maximum power, use games pre-rendered frames (I usually run 1 pre-rendered frame), running with video mode gsync (but using vsync in-game)

In-game settings:

  • No AA (I think it looks fine in 1440 without it)
  • No dynamic resolution
  • All settings high, except clutter, environment, tesselation and character detail that is set to very high
  • Ambient occlusion is set to high, will likely have to disable in Alexandria

Steps to ensure smoothness:

  • Run the game in 60hz fullscreen, set FPS limiter to 60 in-game and use the in-game vsync. If you want to run 30, do the same, except set it all to 30. Probably use 60hz though.

  • Latest nVidia drivers. I do not have an AMD card so I am unsure if the latest drivers for AMD are recommended or not. 388.31 solved microstutter for me.

  • Do not use Rivatuner to cap framerate - RTSS fps cap actually introduced severe stuttering for me.

  • Rightclick the games .exe (installfolder - ACOrigins.exe) and tab to compability. Tick "disable fullscreen optimization". This option has caused stuttering in a lot of games lately, supposedly due to issues with some Windows 10 update. Also tick the DPI-scaling option and set it to program.

  • Many recommend setting the game's processor affinity to normal from high in the task manager, but this did nothing for me. Worth trying though!

Avatar image for Diddies
#12 Posted by Diddies (2320 posts) -

@couly: My machine can't handle it? Is this a joke?

Avatar image for Diddies
#13 Posted by Diddies (2320 posts) -

I have noticed a huge issue with this. It stutters like crazy when I play this game. When I go to try to play other games after playing this, all of my games stutter. I restart my PC and it solves it for the other games. I am unsure what is causing this.

Avatar image for Diddies
#14 Edited by Diddies (2320 posts) -

@RyviusARC: All my newer games are installed on 850 evos. lol

Avatar image for Diddies
#15 Posted by Diddies (2320 posts) -

@Gatygun said:
  • nVidia control panel settings - prefer maximum power, use games pre-rendered frames (I usually run 1 pre-rendered frame), running with video mode gsync (but using vsync in-game)

In-game settings:

  • No AA (I think it looks fine in 1440 without it)
  • No dynamic resolution
  • All settings high, except clutter, environment, tesselation and character detail that is set to very high
  • Ambient occlusion is set to high, will likely have to disable in Alexandria

Steps to ensure smoothness:

  • Run the game in 60hz fullscreen, set FPS limiter to 60 in-game and use the in-game vsync. If you want to run 30, do the same, except set it all to 30. Probably use 60hz though.

  • Latest nVidia drivers. I do not have an AMD card so I am unsure if the latest drivers for AMD are recommended or not. 388.31 solved microstutter for me.

  • Do not use Rivatuner to cap framerate - RTSS fps cap actually introduced severe stuttering for me.

  • Rightclick the games .exe (installfolder - ACOrigins.exe) and tab to compability. Tick "disable fullscreen optimization". This option has caused stuttering in a lot of games lately, supposedly due to issues with some Windows 10 update. Also tick the DPI-scaling option and set it to program.

  • Many recommend setting the game's processor affinity to normal from high in the task manager, but this did nothing for me. Worth trying though!

I had an update that was newer than what you placed. I went ahead and updated it but unsure if that is what did it. I also changed it to 1 pre-rendered frame, but tried in the past and that didn't work. I disables the fullscreen optimization. I think this did it as there is no problems now.

Avatar image for pimphand_gamer
#16 Posted by PimpHand_Gamer (2830 posts) -

@Diddies said:

@couly: My machine can't handle it? Is this a joke?

I thought that when I fired up FF 15 with my i7 8700 and 1080 GPU, cranked up the graphics and it crashed, only playing when I turned some settings down. Guess I'm ready for Nvidia to release their next card.

Avatar image for Diddies
#17 Edited by Diddies (2320 posts) -

@pimphand_gamer: Well I have the Ti version and I do not play at 4k. I play at 3440x1440. My system is more than capable to play these games at these resolutions. I had the 1080 for a short period when I built this system but the day that evga released the FTW3 I purchased. Only had the 1080 for a couple of months.

Also, how are you able to play FF XV already? Just curious?

Avatar image for Diddies
#18 Posted by Diddies (2320 posts) -

@pimphand_gamer: Also AC runs fine now sense I turned off the fullscreen setting off.

Avatar image for RyviusARC
#19 Edited by RyviusARC (5705 posts) -

@Diddies said:

@pimphand_gamer: Well I have the Ti version and I do not play at 4k. I play at 3440x1440. My system is more than capable to play these games at these resolutions. I had the 1080 for a short period when I built this system but the day that evga released the FTW3 I purchased. Only had the 1080 for a couple of months.

Also, how are you able to play FF XV already? Just curious?

FF XV has a playable demo.

Although there is a pirated version already out since someone found out that the if they used the demo's exe file in place of the full game that it would remove the DRM protection.

Someone wasn't being smart when releasing the demo that automatically cracks the full game.

Avatar image for Diddies
#20 Posted by Diddies (2320 posts) -

@RyviusARC said:
@Diddies said:

@pimphand_gamer: Well I have the Ti version and I do not play at 4k. I play at 3440x1440. My system is more than capable to play these games at these resolutions. I had the 1080 for a short period when I built this system but the day that evga released the FTW3 I purchased. Only had the 1080 for a couple of months.

Also, how are you able to play FF XV already? Just curious?

FF XV has a playable demo.

Although there is a pirated version already out since someone found out that the if they used the demo's exe file in place of the full game that it would remove the DRM protection.

Someone wasn't being smart when releasing the demo that automatically cracks the full game.

Forgot about the Demo. Already bought it. Just waiting for Tuesday.

Avatar image for saneal35
#21 Posted by saneal35 (5 posts) -

My friend has the same problem, he has an i7 7700 and a GTX 1070 and every few minutes he gets a huge amount of stutters.

Avatar image for pay2
#22 Edited by pay2 (1 posts) -

This can help you guys. If u have good pc and 16 gb ram and still fighting with stutering I think this is solution. In my case +30 fps and stutering gone.

http://youtu.be/G8pC6iVrjHI

Avatar image for R4gn4r0k
#23 Posted by R4gn4r0k (29841 posts) -

@RyviusARC: I have almost the exact same PC as you:

4790K, 16GB and 1080ti, the game stutters like crazy in areas like Alexandria. And in the other parts of the game I either get zero stutters or I get some stutters.

Seems down to bad optimization from what I can tell.

Avatar image for R4gn4r0k
#24 Posted by R4gn4r0k (29841 posts) -
@Diddies said:

@pimphand_gamer: Also AC runs fine now sense I turned off the fullscreen setting off.

Wow, I can't believe this actually worked.

Was running around Alexandria for 10 minutes and suffered no freezes now.

Why isn't Ubisoft patching this, lol

Avatar image for saltslasher
#25 Posted by SaltSlasher (639 posts) -

I had issues til I locked it to 30fps. Let it hang between 40-50 or trying adaptive stuff it was bad, but when I tried on a non-Freesync monitor, the screen tearing was horrible.